Search This Blog

Loading...

Tuesday, May 24, 2011

Exploded Attribute Text will not be visible when referenced

Remember to check your "Insert" options when bringing in blocks with attributes. You NEVER want to insert those type of blocks with the "Explode" option still toggled on.  Nevertheless, this is a frequent hurdle for designers who are not as familiar with attributes as they SHOULD be.

What is confusing for designers is the fact that they can see the text and think it is a value, but it is typically the attribute tag they are seeing.  The typical steps they take to resolve before requesting assistance include:
  • They double check the entity layer, and find it on a plotting layer
  • They check the reference layer and find that it is thawed, on, and plottable.
  • It is visible in the drawing (xref file) where it is placed, but when that dwg is externally referenced into another file, the text values do not show.
Quick Fix:  Copy the tag name to the "default" value text box when editing the attribute definitions, then cut the definitions to the clipboard and reinsert using "Paste" as block.  Save your file, reload the xref, and your text will magically appear.

Best Practice:  Understand the difference between simple text/mtext and attributed blocks. Ensure that you don't inadvertantly leave the "explode on insertion" option toggled on in the Insert block dialog box.

2 comments:

Mark McClure said...

Thanks, I am working with a drawing with hundreds of these unfortunately. I may try to write a lisp that inserts the tag as text and deletes the attribute.

Anonymous said...

Thanks for this... exactly the situation you described and it was driving me insane.

Thanks for the help.

T